tensorflow-gpu/tensorflow安装后引用报错的解决方法(需降级依赖的情况)

                         QQ:3020889729                                                                                 小蔡

报错原因(以2.0.0版本为例)

pip或conda下载的依赖包不兼容

下载之后得到的tensorflow-gpu/tensorflow存在依赖不兼容,导致我们直接在命令行python/jupyter notebook/pycharm中引用失败。

可能不兼容的依赖如下:(请以protobuf为首选修改情况,尝试解决报错,祝大家安装顺利)

  1. numpy——在tensorflow2.0.0下默认安装的是1.18.x的,该版本tensorflow对它不兼容,使得数据类型有误,导致引用失败。
  2. protobuf——默认安装的3.11.x的,同样出现不兼容,使得Dll无法被链接读取,导致引用失败。

解决方法(降级依赖)

protobuf改为3.6.0版本

1.conda 命令(先卸载再下载低版本的protobuf)

conda uninstall protobuf
conda install protobuf==3.6.0

2.pip 命令(先卸载再下载低版本的protobuf)

conda uninstall protobuf
conda install protobuf==3.6.0

numpy降级为1.16.0

1.conda 命令(先卸载再下载低版本的numpy)

conda uninstall numpy
conda install numpy==1.16.0

2.pip 命令(先卸载再下载低版本的numpy)

pip uninstall numpy
pip install numpy==1.16.0

希望,我的错误经验能够帮大家,最后祝大家都能顺利安装tensorflow——开始探索==What is a machine?==的道路。

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 我行我“速” 设计师:Amelia_0503 返回首页